K perplexity

I want to clear out my iPhone (and Apple Photos) so
that I only retain the images I really want to keep on
my phone. I use Lightroom Classic, and wonder
whether an import of ALL photos from Apple Photos,
deletion from the cloud, then selection and editing
where appropriate, and re-export back to Apple as
JPEGs might be a workable solution. I would like to
keep the EXIF data, and to store the re-exported
images in Date order. Is this a sensible strategy; could
you detail a workflow that would work.

Your strategy is essentially sound, and with the right steps it works well. The key nuance is
managing the file creation date vs. EXIF capture date issue when re-importing back into Apple
Photos. Here's a complete workflow:

Is the Strategy Sensible?

Yes, fundamentally. Importing everything from Apple Photos into Lightroom Classic, culling
and editing, then re-exporting selected JPEGs back to Apple Photos is a well-established
approach. The main pitfall is that when Lightroom Classic exports a JPEG, the file creation date
is set to the export date (not the original capture date), which can confuse Apple Photos' date
ordering. However, the EXIF DateTimeOriginal is preserved in the exported file, and Apple
Photos should use this for its "Photos" timeline view. You may need a small extra step (see
below) to ensure correct ordering in all views. [/ (2] 2]

Phase 1: Export Everything from Apple Photos

Before touching anything, make sure iCloud is set to Download and Keep Originals on your
iPhone (Settings - [Your Name] - iCloud - Photos), otherwise you'll only get low-resolution
proxies. 4

On your Mac, in Apple Photos:

1. Select all photos (¥ A)

2. Go to File > Export - Export Unmodified Original



3. Check the "Export IPTC as XMP" checkbox — this preserves keyword metadata that LRC

will otherwise ignore 2

4. Export to a working folder, e.g. ~/Pictures/ApplePhotos-Export/

Important: Use Unmodified Original (not "Export 1 Photo"), so you get the actual capture
files (HEIC, JPEG, or RAW) rather than re-encoded copies. (¢

Phase 2: Import into Lightroom Classic

1. In LRC, open the Import dialog and point it at your export folder

2. In File Handling, tick "Don't Import Suspected Duplicates" if you already have some of
these images in your catalogue !

3. Set the Destination to your standard date-based folder structure (e.g. YYYY/YYYY-MM-DD)
using LRC's "Organize by Date" option

4. Apply a suitable metadata preset and any import develop preset if desired

5. Import all

Phase 3: Cull and Edit

This is your normal LRC workflow:

* Use flags (P for Pick, X for Reject) or star ratings to cull
¢ Edit selectively in the Develop module

* Run Photo - Delete Rejected Photos to purge rejects from the catalogue (and optionally
from disk)

Phase 4: Clear Apple Photos / iCloud

Once you're confident your LRC catalogue is your master archive:

1. Back up the LRC catalogue first

2. In Apple Photos on Mac, select all and delete — this also removes from iCloud and your
iPhone %!

3. Empty the "Recently Deleted" album in Photos to fully free the space

Phase 5: Export from LRC back to Apple Photos

When exporting selected, edited JPEGs for re-import into Apple Photos:
In the Export dialog, set:

* Format: JPEG, quality 80-90%



* Metadata: Include All Metadata (this preserves EXIF DateTimeOriginal, GPS, camera data)
E])

* File Naming: {YYYY}-{MM}-{DD}_{HH}{MM}{SS}_{original filename} — gives you human-
readable date order in the filename itself

* Destination folder: A staging folder like ~/Pictures/ForApplePhotos/

The date-ordering fix: Apple Photos sorts its main "Photos" view by EXIF capture date, which
will be correct. However, if you notice images out of order in any view, the free workaround is
to use Image > Adjust Date and Time in Apple Photos after import to batch-correct any
stragglers. For a more automated fix, the Mac utility A-Better-Finder-Attributes can set the file
creation date to match the EXIF capture date before import. [l (& 2]

Re-importing into Apple Photos

1. In Apple Photos, File > Import and select your staging folder

2. At the review pane, choose "Keep Folder Organisation" if you organised exports into date-
named subfolders — this creates albums mirroring your folder structure 1

3. After import, verify the "Photos" view (not the "Imports" view) — this is where images
appear sorted by capture date2

Key Points to Watch
Issue Cause Fix
. . . Use A-Better-Finder-Attributes before import, or
Images out of date order in Photos File creation date # EXIF date L
adjust in Photos after
Apple Photos metadata Not included in Unmodified 5
. Use "Export IPTC as XMP" at export stage 1
(keywords/albums) lost Original export
. . LRC handles HEIC natively from . .
HEIC files from iPhone No action needed; edit or export as JPEG
macO0S
. . Some images already in LRC Tick "Don't Import Suspected Duplicates" on
Duplicate risk . 4
catalogue import 4

This workflow gives you a clean, curated Apple Photos library on your iPhone, with LRC as the
authoritative master archive — which aligns well with your existing Lightroom Classic
workflow.



Once re-organisation is achieved, is there a Plugin
that could export LrC Collections to Apple Photos,
again with Collection/Album details and EXIF/Meta

data retained.

There is one dedicated plugin that does exactly what you need, plus a simpler built-in
workaround. Here's the full picture:

LRPhotos Plugin (Best Option)

LRPhotos is a free, open-source Lightroom Classic Publish Service plugin specifically built to
export photos from LRC Collections directly into Apple Photos, with album mapping and
metadata retention. It's the closest thing to a "proper" solution for your use case. 3%

What it does

® (Creates a Publish Service in LRC's Library module, so your Collections appear as Albums in
Apple Photos 22

* Maps LRC Collection names directly to Apple Photos album names, with optional folder
hierarchy (e.g. /2024/Wales Wildlife creates a "Wales Wildlife" album inside a "2024"
folder) (2%

* Preserves EXIF metadata, location/GPS data, and person info — these are explicitly kept on

by default (unlike the standard LRC export which strips them unless you specify otherwise)
[30]

- Tags each imported photo in Apple Photos with “lr:<catalog name>" and “album:<coll¢

* Handles re-publishing gracefully — if you update an image in LRC and re-publish, it
updates the Apple Photos album and tags the old version 1r:out-of-date 2

Caveats to know

® Mac only (uses AppleScript under the hood — no Windows support) 2

* The AppleScript interface for Photos.app has some restrictions: it cannot delete photos or
add images to shared albums, so those actions remain manual 2%

e With large batches, Photos.app sometimes shows a modal confirmation dialog in the
background, which can cause a timeout failure — keep the Photos window visible when
publishing large collections 2%

* Latest release is v2.1.2.0 (November 2024), so it is actively maintained 34



Installation

1. Download the zip from github.com/sto3014/LRPhotos

2. Run install.sh in Terminal — copies the plugin, AppleScript libraries,
and an Automator workflow into ~/Library automatically

3. Restart LRC > the service appears in the Publish Services panel

Built-in LRC Workaround (No Plugin Needed)

If you prefer not to use a plugin, LRC's native Post-Processing export option gets you most of

the way there: 31

1. In the Export dialog, set Post-Processing - After Export > Open in Application >
Photos.app

2. When the export finishes, Photos opens automatically and prompts you to choose (or
create) a destination album

3. This works well for one-off exports, but you must manually specify the album each time —
there's no automatic Collection>Album mapping

This approach still retains all EXIF and metadata as long as you have "Include All Metadata"
ticked in the Metadata section of the Export dialog. 32!

Metadata Behaviour at a Glance

Detail LRPhotos Plugin Native LRC Export to Photos
EXIF/GPS retained 7 Yes (on by default) ¢/ Yes (if "All Metadata" selected)
LRC Collection » Photos Album «/ Automatic A Manual per export
Re-publish / update tracking ¢ Yes X No
Shared albums support X No (AppleScript limit) X No
Folder hierarchy in Photos «/ Yes (via / folder/albumnaming) X No
Cost Free Free (built-in)

For your workflow — where Collections represent curated sets you'll want to mirror faithfully
as Albums in Apple Photos — LRPhotos is clearly the better route. The one-time Terminal
install is minimal, and given your comfort with PHP and WordPress plugin management, it will
feel straightforward.

1. https://www.arrieta.io/iphone-photo-workflow/

2. https://community.adobe.com/feature-requests-676/p-retain-date-and-time-during-jpg-export-according-to-exif-6653
79

3. https://www.youtube.com/watch?v=ATZkYm6BSBg



https://www.arrieta.io/iphone-photo-workflow/
https://community.adobe.com/feature-requests-676/p-retain-date-and-time-during-jpg-export-according-to-exif-665379
https://community.adobe.com/feature-requests-676/p-retain-date-and-time-during-jpg-export-according-to-exif-665379
https://www.youtube.com/watch?v=ATZkYm6BSBg
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. https://asktimgrey.com/2022/01/03/icloud-to-lightroom-classic/

. https://community.adobe.com/t5/lightroom-classic-discussions/optimally-importing-selected-photos-from-apple-pho

to-into-lightroom-classic-on-a-mac/td-p/14701903

. https://asktimgrey.com/2025/09/19/metadata-incompatibility/

. https://www.reddit.com/r/Lightroom/comments/1746f4r/help_exporting for _apple photos with correct date/

. https://www.reddit.com/r/mac/comments/Ippbxd/importing_pics to photos i want to keep date/

. https://discussions.apple.com/thread/8470716

https://www.reddit.com/r/iCloud/comments/15dkewv/w1ll photos and icloud photos preserve folder/

https://www.reddit.com/r/Lightroom/comments/1k6fOvg/lightroom cc and apple photos workflow for/

https://www.lightroomqueen.com/community/threads/my-process-2020-apple-photos-to-lightroom-classic-migratio

n.40739/

https://community.adobe.com/questions-675/culling-photos-in-lightroom-classic-catalogs-using-mobile-devices-9826
86

https://www.youtube.com/watch?v=uDculP6WjkQ

https://www.reddit.com/r/Lightroom/comments/83nvnl/organizationstorage workflow for lightroom and/

https://community.adobe.com/questions-675/lightroom-workflow-with-iphone-973280

https://www.reddit.com/r/Lightroom/comments/ovi82n/lightroom classic_and_importing_iphone_pictures/

https://www.snapsbyfox.com/blog/iphone-only-photography-workflow-adobe-lightroom

https://www.reddit.com/r/Lightroom/comments/1ad0x3k/Ir classic importing_of apple icloud photo images/

https://discussions.apple.com/thread/252812655

https://www.brendanwiltse.com/blog/complete-mobile-photography-workflow-adobe-lightroom

https://www.lightroomqueen.com/community/threads/how-to-keep-shooting-date-as-creation-date-when-exporting.

45787/

https://community.adobe.com/questions-675/lightroom-classic-doesn-t-export-date-of-capture-of-the-photos-944868

https://www.youtube.com/watch?v=0GUzu95Tnal

https://discussions.apple.com/thread/251007281

https://community.adobe.com/questions-675/loosing-exif-data-when-exporting-photos-963394

https://akrabat.com/migrating-to-lightroom-classic-from-apple-photos/

https://www.reddit.com/r/ApplePhotos/comments/14vaz8k/importing_folders subfolders from disk/

https://discussions.apple.com/thread/254921669

https://github.com/sto3014/LRPhotos

https://www.youtube.com/watch?v=s1CJ-hMphgs

https://photofocus.com/software/controlling-metadata-when-exporting-from-lightroom-classic/

https://akrabat.com/migrating-to-lightroom-classic-from-apple-photos/

https://www.youtube.com/watch?v=NYncjluyn2M

https://www.lightroomqueen.com/community/threads/recommended-publishing-sharing-services-workflow-lightroo

m-classic-to-apple-online-2024.50469/

https://helpx.adobe.com/uk/lightroom-classic/plug-ins.html
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https://www.youtube.com/watch?v=CEI-YOWx_HA

https://alloyphoto.com/plugins/usage/

https://helpx.adobe.com/lightroom-cc/using/migrate-apple-photos-library.html

https://community.adobe.com/t5/lightroom-ecosystem-cloud-based-discussions/migrating-lightroom-to-apple-photo

s/m-p/13782856

https://helpx.adobe.com/uk/lightroom-classic/help/whats-new.html

https://www.reddit.com/r/Lightroom/comments/mzboaj/exportingmigration lightroom collections to apple/

https://helpx.adobe.com/au/lightroom-classic/help/prepare-send-or-post-photos.html

https://community.adobe.com/feature-requests-676/p-continually-pull-photos-from-apple-photos-666128

https://www.youtube.com/watch?v=08 hqwnT4JI

https://helpx.adobe.com/uk/lightroom-classic/help/whats-new/release-notes.html

https://www.lightroomqueen.com/community/threads/sync-lightroom-classic-images-into-apple-photos.48704/

https://www.reddit.com/r/Lightroom/comments/1k6fOvg/lightroom cc and apple photos workflow for/

https://community.adobe.com/questions-675/loosing-exif-data-when-exporting-photos-963394

https://www.dpreview.com/forums/threads/how-to-show-exif-data-on-photos-lightroom.4695217/

https://regex.info/blog/lightroom-goodies/ipad-howto

https://community.adobe.com/questions-675/exporting-from-lightroom-catalog-to-apple-s-photos-cloud-service-992
339
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